sur cannot find gems

Added by Léo Dumont about 5 years ago

Hello,

I've installed subtle on my Debian following the instructions on the wiki to compile the last stable version (0.11.3224). It works fine, but I can't manage to install sublets with sur.
When I try to install clock with :
sur install clock
It returns this error:
>>> ERROR: Cannot fin the gem ‘archive-tar-minitar'
>>> Please install it with following command:
>>> gem install archive-tar-minitar

But this gem is allready on my computer, when I do gem list --local I can see "archive-tar-minitar (0.5.2)" in the list. And the files are in /var/lib/gems/1.8/bin

At first I thought it might be a $PATH problem, so I add /var/lib/gems/1.8/bin to it in my ~/.bashrc but sur still gives me the same error saying archive-tar-minitar is missing…

Thanks in advance for your help,


Replies (3)

RE: sur cannot find gems - Added by Christoph Kappel about 5 years ago

Sorry, was a bit busy the last few days.

Did you solve your problem or still struggling with it?

RE: sur cannot find gems - Added by Léo Dumont about 5 years ago

No, I still have the same error with sur.
Any help would be welcome !

RE: sur cannot find gems - Added by Christoph Kappel about 5 years ago

Hm, looks like you have multiple versions of ruby installed. subtle requires ruby >=1.9, it doesn't work when you install it with rubygems for 1.8. There might be something like gem19, gem1.9 or something like that. You have to use this to install the gem.

(1-3/3)